MySQL数据库显示InnoDB:ERROR:the age of the last checkpoint is解决方案

AI 智能摘要
显示:InnoDB: ERROR: the age of the last checkpoint is xxxxx的字样,这是怎么回事呢?其实这个问题一般是因为MySQL的innodb_log_file_size 日志参数设置过小导致的,在数据库里设置或者登陆SSH进行修改就行了。

有的小伙伴在建站过程中,查看MySQL数据库日志的时候,会发现一条报错信息,显示:InnoDB: ERROR: the age of the last checkpoint is xxxxx的字样,这是怎么回事呢?其实这个问题一般是因为MySQL的innodb_log_file_size 日志参数设置过小导致的,在数据库里设置或者登陆SSH进行修改就行了。

如果使用BT宝塔面板的小伙伴,修改就更简单了,如下:

什么?还没安装BT宝塔面板?点击进行下载安装

宝塔服务器面板,一键全能部署及管理,送你3188元礼包,点我领取

1、打开  /etc/my.cnf,修改成合适的参数内容,没有具体值,根据自己的内存实际情况修改,一般是8的倍数

图片[1]-MySQL数据库显示InnoDB:ERROR:the age of the last checkpoint is解决方案-搬主题

2、到MySQL的数据库存放目录,默认在 /www/server/data
删除ib_logfile开头的文件,我这里显示是ib_logfile0和ib_logfile1

图片[2]-MySQL数据库显示InnoDB:ERROR:the age of the last checkpoint is解决方案-搬主题

3、重启MySQL服务

图片[3]-MySQL数据库显示InnoDB:ERROR:the age of the last checkpoint is解决方案-搬主题
© 版权声明
THE END
喜欢就支持一下吧
点赞0 分享
评论 抢沙发

请登录后发表评论

    暂无评论内容