升级失败提示“获取GPG密钥失败:[ Errno 14] curl#37”的解决办法

AI 智能摘要
发现无法升级,提示“获取GPG密钥失败:[ Errno 14] curl#37 - "Couldn't open flle /etc/pki/rpm-gpg/RPM-GPG-KEY-litespeed"”,这是什么情况?也就是无法升级了?

最近搬主题在升级自己其中一台主机的面板的时候,发现无法升级,提示“获取GPG密钥失败:[ Errno 14] curl#37 – “Couldn’t open flle /etc/pki/rpm-gpg/RPM-GPG-KEY-litespeed””,这是什么情况?也就是无法升级了?

因为搬主题的站点是OpenLiteSpeed环境的,安装了CyberPanel面板,在SSH工具中运行 yum update 命令升级的时候会提示获取GPG密钥失败。如下图

图片[1]-升级失败提示“获取GPG密钥失败:[ Errno 14] curl#37”的解决办法-搬主题

经过分析,是因为本地文件缺少RPM-GPG-KEY-litespeed文件,导致无法验证通过,所以才提示失败的。

经过搬主题一番搜索,发现网上有两种解决方案,一种是修改epel.repo文件,让其不验证源文件就可以下载,还有一种是下载官方文件,验证成功即可。这里搬主题选择了第二种方法。

首先,用SSH登陆自己的VPS云主机,然后用如下命令进入/etc/pki/rpm-gpg/目录

cd /etc/pki/rpm-gpg/

然后输入如下的命令下载官方的RPM-GPG-KEY-litespeed文件。

wget https://mirror.cyberpanel.net/litespeed/RPM-GPG-KEY-litespeed

回车后就下载好了,如下图

图片[2]-升级失败提示“获取GPG密钥失败:[ Errno 14] curl#37”的解决办法-搬主题

再次运行 yum update 命令,然后会提示查看到密钥,是否继续,输入y后回车继续。

图片[3]-升级失败提示“获取GPG密钥失败:[ Errno 14] curl#37”的解决办法-搬主题

面板成功升级,问题解决。

图片[4]-升级失败提示“获取GPG密钥失败:[ Errno 14] curl#37”的解决办法-搬主题
© 版权声明
THE END
喜欢就支持一下吧
点赞0 分享
评论 抢沙发

请登录后发表评论

    暂无评论内容