使用Let’s Encrypt发放设置通配符SSL v2图文教程

AI 智能摘要
CyberPanel授予DNS访问权,官方直接提供与Cloudflare和CyberPanel内部DNS经理的直接整合。这一功能简化了SSL证书的发放过程,使其对用户来说更快、更可靠。这里搬主题就分享一下使用Let's Encrypt发放设置通配符SSL v2图文教程。

最近CyberPanel面板增加了一项新功能,即SSL v2。该功能允许用户发放Let’s Encrypt SSL证书,简化了SSL管理过程。以前的SSL管理器功能需要Let’s Encrypt下载针对域名的验证,以确保所有权并颁发SSL证书,与此不同,SSL v2使用基于DNS的验证。这种方法优于基于文件的验证,如果存在重写规则的复杂性或使用Cloudflare等服务,有时会失败。

通过SSL v2,用户可以为他们的域名向CyberPanel授予DNS访问权,官方直接提供与Cloudflare和CyberPanel内部DNS经理的直接整合。这一功能简化了SSL证书的发放过程,使其对用户来说更快、更可靠。这里搬主题就分享一下使用Let’s Encrypt发放设置通配符SSL v2图文教程。

如何从CyberPanel设置通配符SSL?

登录到你的CyberPanel并转到CyberPanel仪表板,然后从CyberPanel仪表板的左侧菜单中点击 “SSL v2″。

图片[1]-使用Let’s Encrypt发放设置通配符SSL v2图文教程-搬主题

现在可为您的域名提供对CyberPanel的DNS访问。

转到 “API设置”。在这里你需要输入Cloudflare电子邮件和全局API令牌。 然后CyberPanel将能够为该域名发出通配符SSL或普通SSL。

图片[2]-使用Let’s Encrypt发放设置通配符SSL v2图文教程-搬主题

全局API令牌将从Cloudflare站点上获得。
对于这个的具体操作类似如下

  1. 转到Cloudflare账户
  2. 单击”我的个人资料”
  3. 选择API令牌
  4. 单击 “查看全局API密钥
图片[3]-使用Let’s Encrypt发放设置通配符SSL v2图文教程-搬主题

如果CyberPanel中的某个域名的DNS没有在Cloudflare内管理,那么CyberPanel DNS将管理该域名的DNS,并被列为权威的DNS来源。

SSL v2旨在自动检测域名的DNS是由Cloudflare还是CyberPanel的DNS管理器管理。因此,无论域名在哪里托管,它都能颁发SSL证书。无论域名的DNS是通过Cloudflare还是CyberPanel DNS管理器管理,SSL v2都能顺利签发必要的SSL证书。

因此,一旦API设置里面保存了API密钥。 然后你就可以进入 “ISSUE SSL”,选择你需要SSL的域名并点击Issue SSL。

图片[4]-使用Let’s Encrypt发放设置通配符SSL v2图文教程-搬主题

在SSL状态中,你会得到状态和详细的日志,如发生在SSL上的情况。同样,你可以选择任何DNS在CyberPanel内管理的网站,你也可以得到这样的SSL状态。

如果域名DNS不在CloudFlare或CyberPanel的DNS上管理。当你试图在该域名上发布SSL时,你将会得到这样的错误。

图片[5]-使用Let’s Encrypt发放设置通配符SSL v2图文教程-搬主题
© 版权声明
THE END
喜欢就支持一下吧
点赞0 分享
评论 抢沙发

请登录后发表评论

    暂无评论内容